brett
  • 0
Новичок

Загрузка более новой версии jQuery в WordPress

  • 0

Я читал о функции WP enqueue_script(), но если я хочу использовать более новую версию jQuery, чем та, что используется в моей установке WP, могу ли я загрузить ее через это, и WP будет использовать последнюю версию? или он загрузит оба? или что будет?

Спасибо!

Share
  1. Позвольте мне сообщить вам, что это плохая идея. Когда мы выпускаем WP, мы тестируем поставляемые с ним скрипты, чтобы убедиться, что они работают. Когда некоторое время назад вышел jQuery 1.5, многие сайты сломались, потому что люди загружали «последнюю» версию jQuery из Google API. WP еще не был протестирован с этой версией, и в результате он убил большую часть экрана администратора. Просто имейте в виду, что может произойти, когда вы начнете замещать проверенные части WordPress своими собственными вещами.

    • 0
  2. Чтобы заменить URL-адрес jQuery по умолчанию, выполните следующие действия:

    wp_deregister_script( 'jquery' );
    wp_register_script( 'jquery', 'your custom url', ... );
    

    Потом звоните wp_enqueue_script( 'jquery' ); как обычно.

    Обратите внимание, что различные страницы в админке WP могут быть несовместимы с никогда не используемыми версиями jQuery, не говоря уже о скриптах плагинов.

    • 0
  3. Вы можете (де) зарегистрировать встроенный jquery со следующими функциями:

    wp_deregister_script('jquery');
    

    И зарегистрируйте новую библиотеку jquery:

    wp_register_script('jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js', array(), '1.4', true);
    
    • 0

Оставить ответ

You must login to add an answer.