derekdowney
  • 0
Новичок

WordPress прекратит поддержку PHP 4?

  • 0

Недавно я занялся разработкой плагинов для WordPress и начал исследовать, как сделать мой код обратно совместимым с php 4+. Последние 5 лет я сосредоточился только на php 5.1+, так что это было тяжелым испытанием.

Во всяком случае, при просмотре некоторых плагинов у одного из них было такое описание:

ВАЖНО: Этот плагин не совместим с PHP 4. Если вы попытаетесь установить его на хост с PHP 4, вы получите ошибку синтаксического анализа. WordPress прекращает поддержку PHP 4 начиная с версии 3.2

Правда ли, что WordPress перестанет поддерживать php до php 5?

Share
  1. Да, версия 3.1 — последняя версия, поддерживающая PHP 4.

    Для WordPress 3.2, который должен выйти в первой половине 2011 года, мы повысим минимальную требуемую версию PHP до 5.2. Почему 5.2? Потому что это то, что использует подавляющее большинство пользователей WordPress, и он предлагает существенные улучшения по сравнению с более ранними выпусками PHP 5. Это также минимальная версия PHP, которую проекты Drupal и Joomla будут поддерживать в своих следующих версиях, которые должны выйти в этом году.

    Основываясь на этой странице объявлений, я на самом деле ожидаю, что 3.2 будет выпущена немного позже в этом году (т.е. в начале 3-го квартала), поскольку 3.1 закончилась на несколько месяцев позже, чем планировалось на этой странице (это не удар по команде разработчиков, к вашему сведению — просто предположение с моей стороны).

    • 0

Оставить ответ

You must login to add an answer.