hanszimermann
  • 0
Новичок

WordPress 2.8 Widget API подходит для разработки плагинов Worpress 3.1.4?

  • 0

Я немного запутался, API виджета WordPress 2.8 относится к версии WordPress 2.8 или относится к версии API?

Должен ли я использовать 2.8 Widget API для написания моего виджета WordPress 3.1.4?

Share
  1. API виджетов был представлен в WordPress версии 2.8. И он все еще используется, так что да, вы можете использовать его для своего WordPress 3.1.4. Вот документы: codex.wordpress.org/Widgets_API

    • 0
  2. API-интерфейсы WordPress обычно относятся к группе функций и концепций и не имеют версий. Любые версии относятся к самому WP (или, в некоторых случаях, к связанным компонентам, разработанным сторонними организациями, такими как jQuery).

    В WordPress версии 2.8 создание виджетов было преобразовано из старого кода (который вас не должен волновать) в новый код на основе классов (который вы должны использовать).

    Так что это не совсем то же самое, что было в 2.8 (скорее всего, это не так), но с тех пор подход тот же.

    • 0

Оставить ответ

You must login to add an answer.