maff
  • 0
Новичок

Перенос WordPress на новый сервер: сообщений не найдено

  • 0

У меня странная проблема с перемещением установки WordPress на новый сервер (только сервер меняется, домен остается прежним, в настоящее время я захожу на сайт на новом сервере через тот же домен и запись в файле hosts). Хотя блог отображается, и я могу получить доступ к области администратора, сообщения не отображаются. Странно то, что экран сообщений показывает правильную статистику («Все (137) | Опубликованные (92) | Черновики (45)»), но в таблице сообщений указано «сообщения не найдены». Во внешнем интерфейсе сообщения не отображаются, но отображаются ссылки «более новые/старые», а в архивах перечислены месяцы создания сообщений. Так вроде находит посты, но почему-то не хватает какой-то важной информации. Я попытался экспортировать/импортировать БД с помощью mysqldump/mysql в командной строке и с помощью phpmyadmin — та же проблема.

Кто-нибудь сталкивался с этой проблемой раньше?

Share
  1. Вы изменили все старые URL-адреса в дампе базы данных, чтобы отразить новое местоположение URL-адреса, прежде чем импортировать его на новый сайт?

    • 0
  2. Сбросьте постоянные ссылки в Dashboard>>Settings>>Permalinks и убедитесь, что WP говорит, что смог внести изменения в файл.htaccess, или внести изменения самостоятельно, но не может записать в.htaccess.

    Вы меняли установленные каталоги? То есть из /wordpress/ в корень? Если да, см. http://codex.wordpress.org/Moving_WordPress.

    И если вы перешли на сервер Windows IIS, убедитесь, что он настроен для обработки красивых постоянных ссылок: http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

    • 0
  3. Войдите в свою админку и перейдите в Настройки/Постоянные ссылки, убедитесь, что ваши ссылки настроены по желанию, и нажмите «Сохранить изменения». Работал на меня.

    • 0
  4. Если изначально вы размещались на компьютере с Linux, скорее всего, ваша команда tar или zip не включала.htaccess. Пересохранение опции постоянных ссылок (или копирование файла.htaccess) должно это исправить.

    • 0
  5. Для тех из вас, кто мигрировал на сервер Nginx, вам потребуется следующее в файле конфигурации, чтобы гарантировать, что постоянная ссылка будет передана в запросе с index.php.

    location / {
        index index.php index.html index.htm;
        try_files $uri $uri/ /index.php?$args;
    }
    

    Недавно я перешел с apache2 на nginx, и это решило эту проблему для меня.

    Источник: http://www.lowendguide.com/3/webservers/wordpress-permalinks-with-nginx/

    • 0

Оставить ответ

You must login to add an answer.