crzr
  • 0
Новичок

Ошибка 404 после публикации поста

  • 0

Моя проблема в значительной степени соответствует названию. Всякий раз, когда я публикую новый пост, все работает нормально — пост отображается в моей панели управления WP, и все выглядит хорошо. Однако, если я попытаюсь «просмотреть сообщение», чтобы просмотреть его в прямом эфире на своем веб-сайте,

Я искал эту проблему по всей сети, и все указывает на редактирование файла.htaccess. Однако эта проблема, скорее всего, связана с темой, которую я разработал (почему? потому что несколько покупателей сообщили об этой проблеме, поэтому мне нужно найти исправление для самой темы).

Тем не менее, редактирование или манипулирование корневым файлом.htaccess на самом деле не вариант, поскольку проблема возникла в моей теме.

Лучший,

Крис

Share
  1. Если вы перейдете на домашнюю страницу своего сайта, вы увидите запись в правильном списке? И если да, то эта ссылка также выдает ошибку 404? Кроме того: чтобы выяснить, является ли это вашей темой или нет, временно установите для своей темы тему Twenty-Ten WordPress по умолчанию, чтобы посмотреть, решит ли это вашу проблему.

    • 0
    • Действительно, пост отображается в моем блоге как любой другой пост, но если я нажму на его постоянную ссылку, чтобы просмотреть весь пост, он вернет ошибку 404. То же самое произойдет, если я попытаюсь просмотреть запись в реальном времени из бэкэнда. Другими словами, всякий раз, когда вы посещаете фактическую ссылку на сообщение, отображается ошибка 404.

      • 0
    • Что произойдет, если вы используете другую тему, например тему WordPress по умолчанию «Двадцать десять» (должна быть включена по умолчанию). Я просто хочу уточнить, будет ли ваша тема вызывать эту проблему или это просто что-то с переписыванием вашей постоянной ссылки.

      • 0
    • Эй, Эван, спасибо за помощь. Я не смог попробовать подход с темой Twenty Ten, так как не смог снова воссоздать ошибку 404. Это означает, что эта проблема возникает на случайной основе. Вот что со мной происходит: abing.gotdns.com/posts/2006/…

      • 0
    • Эй, спасибо, на самом деле, мне было интересно, почему моя проблема «исчезла», и я также повторно сохранил свои постоянные ссылки. Хотя я не могу быть уверен, действительно ли это исправлено, поскольку некоторые пользователи сообщают, что эта проблема может возникать каждый год или около того.

      • 0
  2. Я просто столкнулся с чем-то похожим на это. Это было связано с обновлением постоянных ссылок. Если вы перейдете в «Настройки» -> «Постоянная ссылка» и просто нажмете «Сохранить», посмотрите, решит ли это вашу проблему. Это было для меня. В конце концов я добавил следующее в свой файл functions.php, который обновил для меня постоянные ссылки. Я использовал пользовательские типы сообщений. Возможно, у вас есть плагин, который делает то же самое.

    add_action('admin_init', 'flush_rewrite_rules');
    
    • 0

Оставить ответ

You must login to add an answer.