tkit
  • 0
Эксперт

Как быть с разными версиями jQuery?

  • 0

Например

, если у вас есть плагин на сайте, который использует jQuery 1.5.x, и вы хотите создать новый плагин, реализовав сценарий, использующий более старую версию jQuery, например 1.3.x или 1.4.x.

Я знаю, что это, вероятно, зависит от вызываемых функций jQuery, но если бы вам действительно пришлось использовать как 1.5, так и какую-то более старую версию jQuery… как бы вы справились с такой ситуацией? Возможно ли одновременное использование двух разных версий jQuery без недостатков?

Спасибо.

Share
  1. Можно загрузить несколько версий jQuery, но вам потребуется адаптировать код, который его использует, чтобы ссылаться на правильную версию. Если вы хотите, чтобы это работало с wp_enqueue_script функциями WordPress, вам нужно будет зарегистрировать два разных скрипта, например jquery и jquery_13 . Так что теоретически это выполнимо, но на практике это будет сложно (поэтому я помещаю это в комментарий, а не в ответ).

    • 0
  2. Вы можете использовать jQuery.noConflict в своем новом плагине.

    • 0

Оставить ответ

You must login to add an answer.